Vous avez une question ?

Créer un sujet

internet & fixe ma connexion

Bug Livebox 4 (DHCP ?)

Highlighted
#TopMembre
3 472  

Bug Livebox 4 (DHCP ?)

Bonjour

 

Le forum du Laborange est tellement difficile à utiliser que je décris mon problème ici et je le remonterai ensuite sur le site du Lab'.

 

Dans la rubrique més equipements connectés j'ai cet affichage :

Orange_005_10062016_093738.jpg

 

 

Quelques détails :

Mon Nas est un Lacie Wireless Space

Il fait office de cleint Wifi et de switch

Le PC Moulinsart est sous Win8 et est connecté par Ethernet au switch intégré dans le NAS, son adresse est gérée entièrement par le DHCP de la box, elle n'est pas fixe.

Le NAS est connecté en Wifi  à la Livebox

De plus pour être accessible depuis le NET l'adresse du NAS est définie par un bail DHCP dans la LB4

 

Premier problème quand on affiche le détail de la machine Moulinsart :

Orange_007_10062016_094530.jpgAvec Firefox, l'image peut être agrandie
Clic droit dans l'image --> Afficher l'image. "Page précédente" pour revenir au forum

Comment une machine en adressage dynamique peut-elle se voir attribuer une adresse IP alors qu'elle n'a pas d'adresse MAC ?

 

Je précise que ce bug existe à l'identique sur LB2 et LB3, j'ai toujours ma Livebox Play et dès que l'expé sera terminée, je pourrai de nouveau le montrer. J'ai déjà posté cette anomalie sur le forum.

 

Quelques autres utilisateurs ont déjà remarqué des dysfonctionnement.

Il serait bon de rechercher les fils qui contiennent DHCP dans le sujet du problème.

 

Il y a un problème quelque part dans le fonctionnement du DHCP des Livebox.

L'application de la Livebox Play m'affiche régulièrement la machine Moulinsart à deux endroits de l'arborescence avec deux adresses différentes.

 

Juste pour commencer à documenter le problème la configuration IP de la machine :

Orange_008_10062016_095409.jpg

 

 

Cordialement

PhilDur

Faites confiance aux produits libres : Firefox, Thunderbird, LibreOffice, Irfanview, VLC, 7-zip, FileZilla
Votre machine vous en remerciera
Balises (4)
17 RÉPONSES 17
contributeur occasionnel
3 432  

Re : Bug Livebox 4 (DHCP ?)

Bonjour

 

un ipconfig /all serait déjà plus utile notamment pour voir les adresse MAC.


@PhilDur a écrit :

Bonjour

 

#TopMembre
3 422  

Re : Bug Livebox 4 (DHCP ?)

On n'a pas besoin de la connaitre, une carte réseau n'utilise que son adresse mac pour communiquer en local.

L'adresse Ip n'est utilisée que si on passe par la passerelle.

Ipconfig est une commande qui va disparaitre.

A la limite arp -a est nettement plus utile.

 

Ca ne change rien au problème.

Le DHCP de la box lui affecte une adresse, c'est donc qu'il lui a trouvé une adresse MAC

Pourquoi ne l'affiche t-il pas ?

PhilDur

 

Faites confiance aux produits libres : Firefox, Thunderbird, LibreOffice, Irfanview, VLC, 7-zip, FileZilla
Votre machine vous en remerciera
contributeur occasionnel
3 404  

Re : Bug Livebox 4 (DHCP ?)

L'ipconfig donne aussi des informations sur le bail.

 

A mon avis, la box ne vois tout simplement pas la MAC adresse car elle n'a pas accès en direct à l'interface réseau du PC. C'est le switch qui fait probablement routeur ou sous réseau.

 

D'ailleur si tu regarde le masque de réseau de ton PC tu verras un suffixe /24. En consultant la doc de ton NAS, on peut lire page 15 :

*Le numéro "24" figurant après la barre oblique représente les bits
servant à trouver un sous-réseau. Dans la plupart des cas, ceci n'est
pas important pour l'utilisateur standard.
 
Donc on est bien sur une sorte de sous réseau derrière le NAS.
 
Donc la box ne voit que l'adresse MAC de ton NAS, mais le NAS doit router les demandes DHCP vers ta box. C'est quel mode d'activé sur le NAS ? "Client NAS sans fil "?
 
#TopMembre
3 390  

Re : Bug Livebox 4 (DHCP ?)

Bonsoir

Un switch ne gère pas IP, un switch n'agit qu'au niveau trame.

Le réseau de la Livebox est 192.168.1.0/24

Mon PC est edans le réseau 192.168.1.0/24

Ils sont tous les deux dans le même réseau.

Là tu ne m'apprendra rien ce fut mon métier pendant 42 ans. Pour moi il s'agit des bases, et là, je t'assure que je les connais.

De plus, si j'avais un sous réseau derrière le switch (la machine serait alors en mode routeur et non en mode switch) et pour communiquer du réseau de la Livebox vers l'éventuel sous réseau derrière le NAS, il faudrait spécifier une route statique dans les machines ; en effet en abscence de route statique la passerelle par défaut est la Livebox, elle ne donne accès qu'au réseau Orange (vers le NRA) et n'a aucune connexion vers le supposé sous réseau.

 

Juste pour te prouver que Moulinsart voit bien la box :

C:\Users\PhilDur>arp -a

Interface : 192.168.1.147 --- 0x3
  Adresse Internet      Adresse physique      Type
  192.168.1.1           48-83-c7-36-15-70     dynamique
  192.168.1.18          b0-83-fe-87-c3-98     dynamique
  192.168.1.149         00-00-48-37-ef-bc     dynamique
  192.168.1.150         00-d0-4b-91-07-cd     dynamique
  192.168.1.255         ff-ff-ff-ff-ff-ff     statique
  224.0.0.2             01-00-5e-00-00-02     statique
  224.0.0.22            01-00-5e-00-00-16     statique
  224.0.0.251           01-00-5e-00-00-fb     statique
  224.0.0.252           01-00-5e-00-00-fc     statique
  239.255.255.250       01-00-5e-7f-ff-fa     statique
  255.255.255.255       ff-ff-ff-ff-ff-ff     statique

C:\Users\PhilDur>ping -n 1 192.168.1.1

Envoi d’une requête 'Ping'  192.168.1.1 avec 32 octets de données :
Réponse de 192.168.1.1 : octets=32 temps=1 ms TTL=64

Statistiques Ping pour 192.168.1.1:
    Paquets : envoyés = 1, reçus = 1, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
    Minimum = 1ms, Maximum = 1ms, Moyenne = 1ms

C:\Users\PhilDur>nslookup moulinsart
Serveur :   livebox.home
Address:  192.168.1.1

Nom :    moulinsart.home
Address:  192.168.1.147


C:\Users\PhilDur>

J'insiste, l'application d'administration de la Livebox 4 comporte exactement le même bug concernant le DHCP que celle de la Livebox 3.

 

 

Maintenant les autres bugs relevés par d'autres sur le service DHCP sont-ils liés ?

Seuls les développeurs peuvent répondre à cette question.

 

PhilDur

Faites confiance aux produits libres : Firefox, Thunderbird, LibreOffice, Irfanview, VLC, 7-zip, FileZilla
Votre machine vous en remerciera
contributeur occasionnel
3 358  

Re : Bug Livebox 4 (DHCP ?)

Bonsoir,

 

Il me semble pas avoir laissé entendre que le pc ne voyait pas la livebox, mais que la livebox ne voyait pas l'adresse MAC du PC du fait du passage par le NAS.

 

Je peux me tromper mais le NAS ne doit pas fonctionner strictement que comme switch vu qu'il y a une différentiation entre un port Internet et les autres ports. Un test qui pourrait lever l'incertitude brancher la livebox en cable sur un des ports LAN du NAS.

 

S'il n'était qu'un simple switch  il n'apparaitrait même pas sur la topologie du réseau (vu de la livebox j'entend).

 

A noter d'ailleurs que sur la LB3 (du moins avec le dernière firmware), la carte du réseau n'est pas accessible. Ayant chez moi une configuration Livebox, reliée à un switch sur lequel sont branchés les deux PC, je vois bien les adresse MAC des PC branchés sur le switch dans la liste des baux alloué par la box.

 

Ne vous formalisez pas pour la question sans doute évidente pour vous, la fonction serveur DHCP intégrée NAS a bien été désactivée ? Par défaut le serveur alloue des adresse de 192.168.1.100 à 192.168.1.250. Or comme je vois que l'adresse de moulinsart est à 147 donc pile dans la plage par défaut.

 

Le NAS a quelle IP vu de la Livebox, et son adresse MAC est elle visible de la page de la livebox ?

 

#TopMembre
3 344  

Re : Bug Livebox 4 (DHCP ?) ou LaCie ?


@rv-rv a écrit :

Ne vous formalisez pas pour la question sans doute évidente pour vous, la fonction serveur DHCP intégrée NAS a bien été désactivée ? Par défaut le serveur alloue des adresse de 192.168.1.100 à 192.168.1.250. Or comme je vois que l'adresse de moulinsart est à 147 donc pile dans la plage par défaut.


Je me formalise, mais ce n'est pas bien grave ; c'est mal ? :smileywink:

 

Non seulement j'ai bien écrit switch et pas routeur, mais encore cet équipement se voit attribuer une adresse IP fixe par un bail DHCP au niveau de la box.

L'adresse de Moulinsart est aussi pile dans la plage de la Livebox.

La configuration de NAS :

Orange_001_17062016_091410.jpg

 

Les deux tables de l'onglet Réseau > DHCP de la box pourraient t'intéresser :

Orange_002_17062016_094019.jpg

 


@rv-rv a écrit :

Il me semble pas avoir laissé entendre que le pc ne voyait pas la livebox, mais que la livebox ne voyait pas l'adresse MAC du PC du fait du passage par le NAS.


Ben toi directement non, tu ne l'as pas laissé entendre, mais si la box ne voit pas l'adresse MAC du NAS le réseau local ne peut fonctionner (et ça c'est ce que j'en avais déduit.
Car, pour moi, mais je peux me gourrer, les échanges dans un LAN se font en utilisant les MAC ; l'utilisation d'IP n'est nécessaire que quand aucune interface Ethernet locale ne figure dans le même LAN que le distant ; dans ce cas on utilise la passerelle capable d'accéder au LAN distant (toute la magie du Net dans ce mécanisme) ou la passerelle par défaut.

 

J'admet qu'il pourrait y avoir un problème dans le NAS, j'ai renommé le titre en conséquence, mais ça ne retire pas tout le problème de la Livebox.

On ne peut afficher une adresse IP et l'adresse MAC correspondante dans rien dire si on n'a pas de donnée pour l'adresse MAC.

De plus, pourquoi le DHCP de la box affecte une adresse IP à une machine qui n'a pas d'adresse MAC ?

J'aimerais bien voir la tronche de la table ARP de la Livebox ?

 

Pour moi, si on alimente une application ou un système avec des données erronnées, l'application ou le système se doit de signaler l'anomalie ou d'ignorer les données, mais en aucun cas ça ne doit produire n'importe quoi.

 

Continue à pousser dans les détails on fimira bien par trouver quelque chose !

PhilDur

 

 

Faites confiance aux produits libres : Firefox, Thunderbird, LibreOffice, Irfanview, VLC, 7-zip, FileZilla
Votre machine vous en remerciera
star
3 334  

Re : Bug Livebox 4 (DHCP ?) ou LaCie ?

Bonjour @PhilDur,

Ca ne va peut être pas faire avancer le schmilblick, mais, ici, derrière ma LB4, il y a un switch Netgear Prosafe qui redistribue la connexion à plusieurs machines. Et ces machines sont toutes parfaitement identifiées par leur Ip (venant du DHCP de la Livebox) et leur adresse Mac !

 

J'ai aussi testé en intercalant un petit routeur Wifi (Netgear PR2000 en mode "extension du réseau local") entre la Livebox et mon Pc portable. Là aussi, machine bien identifiée (Ip et Mac) par la Livebox.

 

Si la Livebox Play précédente me causait de temps en temps une non attribution d'adresse Ip sur les machines connectées en Ethernet, depuis la Livebox 4, et sans changer la configuration de mes machines, je ne rencontre plus ce genre de souci.

 

Dans ta photo d'écran, je vois une prise Rj45 du Nas avec une Ip en 172.20.0.1. Tu redistribues sur un autre réseau Ip ?

 

Ton problème ne viendrait-il pas du switch intégré au Nas ?

 

Bonne recherche...


Cordialement, mg36
#TopMembre
3 319  

Re : Bug Livebox 4 (DHCP ?) ou LaCie ?

Finement observé.

Cette prise ne sert qu'en cas de problème, quand le NAS est dans une configuration où on peut le perdre, un des prises Ethernet est configurée en dur, pour permettre de le reconfigurer.

Imagine que le le déménage et que je n'ai pas d'accès wifi ... je n'aurai pas la main dessus !

 

Mais oui, le problème pourrait bien venir du switch, mais la box ne devrait jamais accepter d'afficher une adresse MAC vide alors qu'elle l'utilise

PhilDur

Faites confiance aux produits libres : Firefox, Thunderbird, LibreOffice, Irfanview, VLC, 7-zip, FileZilla
Votre machine vous en remerciera
contributeur confirmé
3 304  

Re : Bug Livebox 4 (DHCP ?) ou LaCie ?

Bonjour,

 

J'ai fait remonter le bug auprès d'un conseiller de la cellule expertise. Il m'a fait changer de LB4... pareil. Et j'ai raté son appel pour lui confirmer que ça ne venait pas de mon précédent matériel. Je l'ai aussi signalé dans le sujet épinglé du forum.

 

Autre point : Si on désactive le DHCP, et que, pour X raison, on redémarre la box (même 4 jours après hein), elle réactive le DHCP.

 

Bon je passerai sur la réponse du conseiller par chat me demandant si j'étais sur une rallonge électrique... sans commentaire.

 

Avant j'avais 2 Livebox2 pour faire de l'aggrégation de ligne via le service et le matériel d'un autre FAI. Lundi je reçois un switch pour tenter la connexion en étoile plutôt qu'en série. Et les techniciens (des vrais) de l'autre FAI suivent mon problème de près. Donc oui, il y a bien un souci sur la LB4 et le DHCP.

 

 

 

Vous avez une question ?

Créer un sujet
À la une

Découvrez nos bons plans de Noël pour faire plaisir à toute la famille !

Trouvez les réponses à toutes vos questions

De nombreuses discussions sur les sujets qui vous intéressent :

197 membres connectés
et 3676 invités

Tous les membres en ligne

Infos utiles sur la Fibre

Tout savoir sur la Fibre